[Solución] Library not loaded: /usr/lib/libcrypto.0.9.dylib y SHA1 error

[Solución] Library not loaded: /usr/lib/libcrypto.0.9.dylib y SHA1 error.

Leopard (incluso con el update 10.5.1) tiene una versión de una biblioteca que tiene solo la arquitectura PowerPC, por lo cual cuando alguna aplicación la usa se cae sin remedio. El error que van a ver es como este:

————————————-
Dyld Error Message:
Library not loaded: /usr/lib/libcrypto.0.9.dylib
Referenced from: /Library/Frameworks/net.juniper.DSCoreServices.framework/
Versions/5.5.0/net.juniper.DSCoreServices
Reason: no suitable image found.  Did find:
/usr/lib/libcrypto.0.9.dylib: mach-o, but wrong architecture
/usr/lib/libcrypto.0.9.dylib: mach-o, but wrong architecture
————————————-

Solución:

Abrir la terminal.app y ejecutar esta secuencia de comandos:

cd /usr/lib
sudo cp libcrypto.0.9.dylib libcrypto.0.9.dylib.old
sudo cp libssl.0.9.dylib libssl.0.9.dylib.old
sudo ln -sf libcrypto.0.9.7.dylib libcrypto.0.9.dylib
sudo ln -sf libssl.0.9.7.dylib libssl.0.9.dylib

Problema 2)

Si utilizan algún parche hecho con iPatcher en Leopard nunca funciona dando un error: SHA1 error.

Para solucionarlo hay que “Mostrar el contenido del paquete” de la app del parche, ir a la subcarpeta Contents/MacOS y sustituir el binario iPatcher por este:

http://rs206.rapidshare.com/files/66524321/iPatcher.zip

Luego de eso ejecutan el app parcheador y funciona.

Más información.

victor lopez Sobre mí Esta noticia ha sido creada el 10 Diciembre 2009 a las 21:28 en InicioActualidad[Solución] Library not loaded: /usr/lib/libcrypto.0.9.dylib y SHA1 error y si quieres puedes comentarla.
Si te ha gustado [Solución] Library not loaded: /usr/lib/libcrypto.0.9.dylib y SHA1 error y esta web, puedes seguirla a través de Facebook, Twitter y también puedes recibir las nuevas noticias de la web en tu correo pincha en este enlace para darte de alta. Además también puedes seguir las noticias por RSS.